>>179
If you are running a frontend (e.g. Caddy or another HTTP server) which reverse proxies requests to Sriracha, and you have ensured the file size limits in Sriracha are configured appropriately, then this should be resolved by increasing the maximum request size in the frontend.
I'm not familiar with CloudFlare, but if you are running behind CF, the same principle applies.
If you aren't using any frontends (you are accessing Sriracha directly) and still get this error for sizes smaller than the configured limit, it is a bug in Sriracha. If this is the case, please let me know the exact values of the max thread and reply file size board options, as well as the exact byte size of the file causing the issue (du -b file.zip) so I can try reproducing the issue.